SSH authentication using key pairs

October 3rd, 2013 No comments

This is more of an aide-mémoire for me than a public guide. If it is helpful for other people then I am happy to make it available. If anyone has any comments or suggestion please contact me.

. . .

This example is for Debian however it should work on most flavours.

  • Log on to the client machine as the user who will be accessing the server
  • Generate a key pair using the following command:
$ ssh-keygen
  • Use the default directory to save the key
  • [optional] To use SSH authentication without entering a password simply hit enter (otherwise enter a pass phrase)
  • The key will be created and stored in the ~/.ssh directory
  • We now need to install the generated key on the server using the following command:
$ ssh-copy-id -i .ssh/id_rsa.pub username@serverip
  • When asked enter the password to log on to server. The key will then be added to the server and confirmation message will be displayed.
  • Finally a bit of housekeeping / security. Protect the SSH keys:
$ chmod go-w ~/
$ chmod 700 ~/.ssh
$ chmod go-rwx ~/.ssh/*

That should be it…

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Categories: Debian, Linux, SSH Tags: , ,

Once more unto the breach, dear friends, once more…

October 1st, 2012 1 comment

OK, so I have decided to start yet another ‘project’..! Aside from the ongoing restoration of my old Land Rover (see my earlier posts), I am starting the resurrection of a classic computer, notably a D.E.C. PDP-8 ‘Straight Eight’. It has spent the last twenty plus years gathering dust, mold and rust at the back of a garage owned by a late friend of mine.

Here it is, in all its glory…

As you would probably have guessed, it isn’t in the best of conditions. The casing has several cracks and there are a few missing switches on the control panel. There is also considerable corrosion on the wiring loom and connection blocks.

The damage to the control panel…

The damaged outer casing…

On a plus side, it is complete and I have managed to find a good collection of the original documentation. The memory core is also still tightly sealed, so hopefully that should be in good condition.

The core memory module…

A view from the top…

This will be a slow project, for several reasons:

  • I don’t want to screw it up!! They only made ~1400 of this type and I would hate for there to be one less due to my stupidity.
  • This is a learning project, how better to learn about the inner workings of a computer than by rebuilding one.
  • This particular machine has a good deal of history attached to it (see first point).
  • It belonged to a dear friend of mine and I would like to do him proud…

There will be more to follow soon, plus hopefully a little bit of the back history.

VN:F [1.9.22_1171]
Rating: 10.0/10 (1 vote cast)
VN:F [1.9.22_1171]
Rating: +2 (from 2 votes)

Its Alive!!

March 14th, 2012 No comments

It has been a while since the last post (some crazy fool decided to start moving house), busy busy busy…

Anyway, tonight was a major milestone, as I got the engine up and running. And it was surprisingly easy. I had expected problems, as this engine has sat unused for two years. However, I connected the fuel line, filled up the radiator, applied power and it started, instantly..! I was amazed, completely amazed. I thought it would turn over for a few minutes before it decided to cough into life, but not after just one crank. Plus there was very little smoke, which was nice…

Also the new exhaust pipe I made was working well. All in all very pleased.

And so to bed…

VN:F [1.9.22_1171]
Rating: 9.3/10 (3 votes cast)
VN:F [1.9.22_1171]
Rating: +3 (from 3 votes)
Categories: 200Tdi, Land Rover, Series III, YouTube Tags:

Exhausting Work..!

December 23rd, 2011 No comments

I’m sorry I couldn’t help it… The pun that is… Not the… Err, never mind…

As it is nearing Christmas, my spare time has been eaten into and the time available for frivolous Land Rover work has dwindled. However, I did manage to fabricate a new exhaust pipe. The original one had a few spots of rust and needed a new downpipe to connect to the diesel manifold. I am running the 200Tdi without the turbo fitted as it would have been too powerful, without it, it should provide a similar BHP to a good 2.25 petrol. I decided (as is my way) to build a new one from scratch.

A visit to my local hardware store and I had all the mild steel I needed…

The start of the new downpipe...

I started by cutting a piece of plate steel to match the outlet on the manifold (as can be seen at the top of the picture above). Then I slowly cut and tacked into place the pipe sections, angling them out and under the chassis. One of the things I wanted from the start was a smooth finish. I have seen other similar exhausts where the cuts and joints were welded together and left. Not the best look!

The downpipe fitted...

Once I was happy with the position and placement of the downpipe I continued back to the muffler. I made this from two pieces of box section. On the sides that met I drilled one hundred and twenty 4mm holes to allow the gas to pass through. This is almost exactly the same method used in the original muffler, it is only the external shape that has changed.

The downpipe and muffler...

As you can see I added a joint plate to allow for easy fitting. I also used the original mounting bracket (it lined up perfectly). Because of the increased weight of the muffler I added an additional bracket to the rear. The exhaust is made from steel almost four times the thickness of the original, so it tends to weigh a ‘tad’ more.

The rear support and exit pipe...

It took about ten hours in total to make, it could have been less if I had left the surface weld on the joints. However, I am very pleased with the result. The final thing to do is spray it with high temperature ‘stove’ paint…

…meanwhile…

The dashboard fitted...

I have also been working on the dashboard and internal parts. It doesn’t look it, but there isn’t that much work left to do. I will not meet my original Christmas deadline, however, I feel confident that I can have it ready by the end of January…

 

Honest..!

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

It’ll be done by Christmas… Honest!

November 10th, 2011 No comments

I have set myself (some may say an insurmountable) challenge of rebuilding my old SIII 109 Land Rover and getting it on the road before Christmas. As you can see from my earlier post, it hasn’t moved in over six years. However, these are minor trifles, so what if the engine hasn’t run in all that time, or that the bodywork has gathered (in some places up to an inch of ) moss. These are problems that can be fixed with enthusiasm, determination and elbow grease.

I had wanted to keep a ‘day-by-day’ or ‘week-by-week’ blog post on how I was progressing, however, time being a luxury it slipped down in my priorities. I shall make up for that with this post.

"Will you walk into my parlor?" said the spider to the fly...

The project started properly in early September and the first thing to do was a complete strip down, to see what the damage was and to see what work was needed. I was surprised at how quickly happened! Over a period of two days it went from being 99.9% complete to just a chassis.

The doors have come off...

Floor and seating gone...

I was helped by my friend Jim with the big bits such as the roof, a task that would have been almost impossible if I were working on my own. Thanks Jim..!

Off comes the roof...

It can be difficult sometimes to decide what to take off next. You can get overwhelmed by the scale of it. However, I found that the best approach was to focus on small bits and forget about the rest. Before you know it you are half way…

About half way...

I managed to lift the rear tub off all by myself, something I would not advise to anybody..! It is a two man job at the absolute bare minimum…

Last few items remaining...

It came as a great relief the amount of (or should I say ‘lack of’) rust damage. I had imagined the worst, however, the chassis was in very good condition. The only visible damage was a small patch on the rear cross member (no surprise there I hear you say). It was only a very minor bit of surface rust, nothing a good wire-brush wouldn’t fix.

The only bit of rust to be found on the chassis...

The worst of the rust damage was with the main cross-member on the tub. It was being held together by the rivets. This would need completely replacing.

Main cross-member on tub completely rusted away...

Other than that there were only a few spots of rust on the rest of the body, a little on the door bottoms and the footwells in the bulkhead.

The corrosion damage to the tub caused by the rusted cross-member...

The first bit of restoration was to make a replacement cross-member for the tub. Yes, you can buy them, but that is not my style, plus you can have great fun over engineering it. Here is my version, all made from 4mm mild steel, over twice the thickness of the original part.

OK, so, it is a 'little' over engineered..!

My plan was to upgrade the engine and fit a 200Tdi. I had picked one up from eBay a while back and now was the time to dry-fit it. I still find it amazing how many of the parts from Land Rover are interchangeable, the series gearbox fitted perfectly to the engine (see my post on fitting 200Tdi for more detailed info [link to follow]). I ‘borrowed’ the engine mounts from the 2.25 petrol I had taken out and the engine dropped in without a hitch. It was good to feel I had made a turn and was now starting to put things back on.

The dry-fit of the 200Tdi engine and gearbox...

Next I had to work out how to mount the radiator. The original radiator was damaged and leaked like a sieve. Two brackets mounted on the front chassis cross-member, a plate on the top and we’re good to go (I shall post photos of these when I get the chance).

Positioning the radiator before fabricating the mounts...

The part that was causing me most of my worries was the front axle. One of the main reasons the Land Rover was taken off the road in the first place was the damage caused by the seizing up of the diff, this in turn caused the two half shafts to shear off..! (great fun) Anyway, I found a donor SIII axle (again on eBay) and so took to salvaging the parts needed. A couple of nights later and it is looking as good as new, ready to be put back on. The rear Salisbury axle was still in perfect condition, a few very minor spots of surface rust on the outer casing.

The fully restored front axle ready to be fitted...

Next on my list was the bulkhead. On the whole it wasn’t in too bad a condition, again a few spots of rust here and there. However, I did want to prepare it properly and prevent future rusting, so out came the wire brush and after a good coating of acid-etch primer it was sprayed with several coats of grey primer.

It is important to say at this point that I am not trying to restore this back into showroom condition. All I want to do it put it back as a solid work-horse. So the final finish of the paint is not a major concern of mine. I have had to keep reminding myself of this after spending hours cleaning one small part. If I had the time, then yes, I would spend as long as needed on each and every piece. However, I have set myself the goal of getting it back on the road for Christmas. As long as it looks clean and is in good condition I will be happy..!

The bulkhead all cleaned and primed...

More to follow…

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Ubuntu Desktop 10.10 ‘libfaac’…

September 16th, 2011 No comments

This is more of an aide-mémoire for me than a public guide. If it is helpful for other people then I am happy to make it available. If anyone has any comments or suggestion please contact me.

. . .

After installing Ubuntu from scratch and if you are trying to use FFMPEG to encode ‘aac’ audio streams you may find you are missing the ‘libfaac’ library. It is simple enough to install using apt-get:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list && sudo apt-get -q update && sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring && sudo apt-get -q update

Then run:

sudo apt-get install ffmpeg libavcodec-extra-52

And you will now have the library available…

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Categories: Linux, Ubuntu Tags:

Playing DVDs with Ubuntu Desktop (10.10)…

August 2nd, 2011 No comments

This is more of an aide-mémoire for me than a public guide. If it is helpful for other people then I am happy to make it available. If anyone has any comments or suggestion please contact me.

. . .

After installing Ubuntu Desktop (10.10) you need a few extra packages to read/play DVDs. These packages are provided by: http://www.medibuntu.org/

First thing to do is open up a terminal window and add the new source locations to APT:

$ sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list

Then update APT and install the mediabuntu keyring:

$ sudo apt-get update
$ sudo apt-get install medibuntu-keyring
$ sudo apt-get update

Then install the required packages:

$ sudo apt-get install libdvdcss2

(Optionally) Install the w32 codecs to support (wmv, quicktime, realplayer):

$ sudo apt-get install w32codecs

If you haven’t already done so install VLC (the absolute king of media players):

$ sudo apt-get install vlc

If all went well you should now be able to play DVDs…

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Categories: Computer Hardware, DVD, Films, Linux, Ubuntu Tags:

Installing debug FlashPlayer for Firefox on Ubuntu 10.10

July 20th, 2011 No comments

This is more of an aide-mémoire for me than a public guide. If it is helpful for other people then I am happy to make it available. If anyone has any comments or suggestion please contact me.

. . .

  • First install the ‘Adobe Flash Player plug-in’, through the ‘Software Centre’ (alternatively it can be done from the command line if you like)…
  • Download the Debug Flash Player:
$ cd ~/Downloads/
$ wget http://download.macromedia.com/pub/flashplayer/updaters/10/flashplayer_10_plugin_debug.tar.gz
  • Extract the files:
$ tar -xzvf flashplayer_10_plugin_debug.tar.gz
  • Copy ‘libflashplayer.so’ to the Flex SDK folder:
$ sudo mv libflashplayer.so /opt/flex/runtimes/libflashplayer.debug.so
  • Update alternatives reference:
$ sudo update-alternatives --install /usr/lib/flashplugin-installer/libflashplayer.so firefox-flashplugin /opt/flex/runtimes/libflashplayer.debug.so 60
  • (optional) Check alternatives reference:
$ update-alternatives --display firefox-flashplugin
firefox-flashplugin - auto mode
  link currently points to /opt/flex/runtimes/libflashplayer.debug.so
/opt/flex/runtimes/libflashplayer.debug.so - priority 60
/usr/lib/flashplugin-installer/libflashplayer.so - priority 50
Current 'best' version is '/opt/flex/runtimes/libflashplayer.debug.so'.
  • Restart Firefox and type ‘about:plugins’ into the address bar to check the plug-in is loaded.
VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Install and configure Adobe Flex SDK on Ubuntu 10.10

July 20th, 2011 No comments

This is more of an aide-mémoire for me than a public guide. If it is helpful for other people then I am happy to make it available. If anyone has any comments or suggestion please contact me.

Requirements

  • The Flex SDK (build 4.5.1.21328 at the time of writing)
  • Java (version 6 at the time of writing)

Installation

  • If it isn’t already installed we need Java. Open up a terminal window and type the following:
$ sudo apt-get install java-package sun-java6-jdk

This may take a few minutes, plus you will have to agree to the license.

  • Download the Flex SDK (see link above) and save it to your Download folder.
$ cd ~/Downloads/
$ wget http://fpdownload.adobe.com/pub/flex/sdk/builds/flex4.5/flex_sdk_4.5.1.21328.zip
  • Create a folder to copy the files to:
$ sudo mkdir /opt/flex
  • Unzip the Flex SDK files:
$ cd ~/Downloads/
$ unzip flex_sdk_4.5.1.21328.zip -d flextmp
  • Copy extracted files to final resting place:
$ sudo mv flextmp/* /opt/flex/
  • Add Flex compiler path to “~/.bashrc”:
$ gedit ~/.bashrc

And add the following to the bottom of the file:

export PATH=/opt/flex/bin:$PATH
  • That should be it. To test just call the compiler (after closing any open terminals):
$ mxmlc -help
VN:F [1.9.22_1171]
Rating: 6.0/10 (2 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Categories: Flex, Linux, Software Development, Ubuntu Tags:

After six years… Movement!!

March 8th, 2011 No comments

It has been over six years and my poor old landrover has been patiently waiting for someone to show it a bit of affection. That time has finally come… On Saturday (05/03/2011) I, along with my friends Dave and Jim, started the task of moving my SIII 109″ from its resting place to a new home. Years of growth had to be cut back. The brambles didn’t give up  the fight easily and after three hours of blood, sweat and tears we had access.

After hours of bramble bashing contact is made...

Next came the task of trying to move the beast! There was no way in this world I was going to try starting the engine, even if it did by some miracle jump into life, I didn’t want to risk mechanical damage. As it was unable to move under its own power I was left with two options, push it (yeah good luck with that one!), or pull it out. Dave’s father had kindly offered the use of his Transit, so we hitched up a length of rope and began to pull…

Nothing, except the first tantalising whiff of burning clutch. Hmmm! A mechanical seizure had always been a concern of mine. So out came the block’n'tackle and a length of chain. If we were unable to pull it out, maybe we could drag it out. Luckily my father had (many years ago) fitted a steel gatepost and, as was his way, it had been (slightly) over engineered. You could have moored an oil tanker to it with no problem! It made the ideal anchor point for fitting the lifting gear. After several tugs it was obvious that three of the wheels were rotating freely, one however was locked solid. However, after a little bit of swearing and a few more tugs there was a sudden ‘clunk!’ sound and the rear wheel started to turn. I suspect it was a spot of rust between the brake shoe and drum. I hope that’s all it was! I won’t know until I strip it down.

This sudden freedom of movement allowed us to try the Transit again and other than a little bit of 3-point turning (again, all by hand) we had the lanny on the driveway…

Out of the jungle and onto the open road...

Part 2 – The open road

It was such a relief to see it parked on the road. So many things could have conspired to prevent us getting to this point. It was now a (simple) job of towing the lanny to its new home. And it really was simple! Other than a slight metallic rattle from the gearbox it couldn’t have gone smoother…

The only other bit of hard work was pushing it up the drive and into the garage. Dave volunteered to drive, Jim and I pushed. Five minutes and the job was a good’n!

Now starts the hard part, the strip, clean and assemble…

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)